Jump to content
CNS

AS350B2 Horn light on ground engine off

Recommended Posts

Hi there!

Got the HORN light lit with engine OFF. It goes OFF when I push on it - but no klaxon, and when I remove the switch.

No voltage at the horn itself. 

There's a relay on the left side of the console, deep in the nose. I noticed it activate when I push on HORN (on an other machine), but I have no idea what that relay is for. I tried on my machine, that relay didn't click, changed it, nothing changed.

Checked the relay on a PCB under the pushbuttons. Seems good.

Any ideas on what it could be?

Share this post


Link to post
Share on other sites

You could also look at the hydraulic cut-off switch on the collective. Try cycling the switch on and off a few times, or pull the switch out and look at the solder joints on the back.

 

 I have had a loose or broken wire give similar issues in the past. 

Share this post


Link to post
Share on other sites

Well I pulled it out, solder joints were very nice. Put it back, cycled more then light turned off, horn worked correctly.. will get ready to change the switch when necessary.

That was an easy fix, will keep that in mind before opening everything next time! Thanks a lot!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...